# CONTENTS

1 Welcome to Conform 3
1.1 Default Conform Window 3
1.2 Main Toolbar 4
1.3 Mouse Modes 5
1.4 Conform Menus 5
1.5 Supported File Types 9
1.6 Keyboard Shortcuts 9

2 Import Data 11
2.1 How to Import Data 11

3 Projects 15
3.1 Project Browser Controls 15
3.2 Start a New Project 15
3.3 Open an Existing Project 16
3.4 Saving Projects 16
3.5 Groups 16
3.6 Priority 18

4 Maps 21
4.1 Navigating the 2D Map 21
4.2 Mouse Modes 21
4.3 Go To Location 22
4.4 Map Scale 23
4.5 Map Measurement Tool 24
4.6 Set Coordinate System 25
4.7 3D Preview 27

5 Base Maps 33
5.1 Adding a Base Map 33
5.2 Add Default Base Map 34
5.3 Clear Default Base Map 34
5.4 Add New Base Map 34
5.5 Clone Base Map 36
5.6 Edit Base Map 38
5.7 Delete Base Map 39

6 Address Lookup 43
6.1 Lookup Address 43

7 Layers & Features 45
16.2 Requesting a Trial ................................................................. 119
16.3 Using a Purchased License ............................................... 123
16.4 Offline Licensing ............................................................... 125
This is the documentation for Conform 1.3.0, generated on November 17, 2015.
Conform is a powerful, easy-to-use tool for processing your GIS data. Whether you are a new or experienced GIS user, you will find Conform a useful tool to view, edit, and analyze your data. Conform provides the ability to drag and drop files and folders and supports a wide variety of GIS formats.

1.1 Default Conform Window

Conform will start with the following interface.
Each number indicates a different toolbar or window within Conform.

1. Menus. See *Conform Menus* for more information.
2. Main Toolbar. See *Main Toolbar* for more information.
3. Project Browser. See *Project Browser Controls* for more information.
4. 2D Map. See *Maps* for more information.
5. Log Output. See *Log Output* for more information.
6. Task Monitor. See *Task Monitor* for more information.

### 1.2 Main Toolbar

The items in the main toolbar can be used in place of keyboard shortcuts or menu items when available.

- **New Project** – Creates a new project in Conform. This can also be accessed through the File Menu.
- **Open Project** – Opens an existing Conform project. This can also be accessed through the File Menu.
- **Save Project** – Saves a Conform project. Save Project will overwrite an opened Conform project or prompt to save a new Conform project. This can also be accessed through the File Menu.
- **Toggle 3D Preview** – Presents a 3D Preview of data within a Conform project.
- **Undo** – Undo the previous action performed.
- **Redo** – Redo the previous action performed.
- **Add Base Map** – Add Bing or MapQuest base maps to loaded data files. Base Maps will be added as a new layer that can be toggled on and off.
- **Look Up Address** – User is able to look up an address within loaded data files.
**Go To Location** – User is able to enter a known latitude and longitude.

**VCDR Navigation Tool** – User is able to run the VCDR Navigation Tool.

### 1.3 Mouse Modes

Mouse Modes in Conform provide a variety of functions in the 2D Map. They function as radio buttons, meaning that only one option can be selected at a time.

- **Pan and Zoom** – User can pan the map using a click and drag method. User is able to zoom using the scroll wheel of a mouse.

- **Select Features** – User is able to select a rectangular portion of the map using a click and drag method. Selections will be outlined.

- **Edit Tool** – User is able to toggle this function to edit layers, building locations, polygons, etc.

- **Vertex Edit Tool** – Toggles the vertices for polygons to be edited and adjusted.

- **Measurement Tool** – Users can measure distances and areas by drawing lines and polygons over the map view.

- **Feature Identify** – User is able to identify a feature from within the 2D Map.

### 1.4 Conform Menus

#### 1.4.1 File

The File menu allow for creation, opening, and saving of Conform projects. For more information, see the *Project Browser Controls* section.

![Conform User’s Guide, Release 1.3.0](image)

#### 1.4.2 Edit

The Edit menu allows users to perform the Undo and Redo actions.
These functions are also available on the *Main Toolbar.*

1.4.3 View

The *View* menu allows users to control what they see within Conform.

Items within the *View* menu can be toggled on and off by selecting the box next to the name. If an item is toggled on, it will have an *X.* If an item is toggled off, the box will be blank.

A status bar can also be enabled across the bottom of the Conform window to monitor data input.
1.4.4 Map

The *Map* menu allows users to perform functions within the 2D map.

Users can *Zoom to selected layers*, *Zoom to selected features*, or *Clear feature selections*. 
1.4.5 Tools

The *Tools* menu provides access to the *Add Base Map...*, *Look up address...*, and *Model Search Paths...* tools. Some tools can also be found on the *Main Toolbar*.

*Model Search Paths...* allows users to specify the search path for models which otherwise could not be located relative to the Shapefile referencing them.

1.4.6 Help

The *Help* menu provides access to the PDF *Users Guide* downloaded with the user’s Conform installation. It also provides access to *About Conform*, which will show the version, license holder, license expiration, and license ID.
1.5 Supported File Types

Conform will recognize each of the file types below when they are dragged and dropped into the program.

<table>
<thead>
<tr>
<th>File Types</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shapefiles</td>
<td>.shp</td>
</tr>
<tr>
<td>GeoTiff</td>
<td>.tif</td>
</tr>
<tr>
<td>DTED</td>
<td>.dt0, .dt1, .dt2</td>
</tr>
<tr>
<td>DEM Elevation Grid</td>
<td>.dem</td>
</tr>
<tr>
<td>Arc/Info Binary Grid</td>
<td>.adf</td>
</tr>
<tr>
<td>Arc ASCII Grid</td>
<td>.asc</td>
</tr>
<tr>
<td>MrSID</td>
<td>.sid</td>
</tr>
<tr>
<td>ECW</td>
<td>.ecw</td>
</tr>
<tr>
<td>ERDAS Imagine</td>
<td>.ige</td>
</tr>
<tr>
<td>CADRG and CIB in Raster Product Format</td>
<td>RPF</td>
</tr>
<tr>
<td>JPEG 2000</td>
<td>.jp2, .j2k</td>
</tr>
<tr>
<td>LAS LIDAR</td>
<td>.las</td>
</tr>
</tbody>
</table>

1.6 Keyboard Shortcuts

The following keyboard shortcuts can be used at any time within Conform.
### Combination Keys

<table>
<thead>
<tr>
<th>Combination Keys</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control-x</td>
<td>New Project</td>
</tr>
<tr>
<td>Control-O</td>
<td>Open Project</td>
</tr>
<tr>
<td>Control-S</td>
<td>Save Project</td>
</tr>
<tr>
<td>Control-Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Control-Y</td>
<td>Redo</td>
</tr>
<tr>
<td>Control-B</td>
<td>Add Base Map</td>
</tr>
<tr>
<td>Control-F</td>
<td>Look Up Address</td>
</tr>
<tr>
<td>Control-L</td>
<td>Zoom to selected layers</td>
</tr>
<tr>
<td>Control-T</td>
<td>Zoom to selected features</td>
</tr>
<tr>
<td>Control-D</td>
<td>Clear feature selection</td>
</tr>
<tr>
<td>Control-Q</td>
<td>Exit</td>
</tr>
<tr>
<td>Alt-D</td>
<td>Import Data</td>
</tr>
</tbody>
</table>

### 1.6.1 Mouse Mode Keyboard Shortcuts

The following keyboard shortcuts can be used to select different modes within Conform.

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Pan and Zoom</td>
</tr>
<tr>
<td>2</td>
<td>Select Features</td>
</tr>
<tr>
<td>3</td>
<td>Edit Tool (only if in Editing Mode)</td>
</tr>
<tr>
<td>4</td>
<td>Vertex Edit Tool (only if in Editing Mode)</td>
</tr>
</tbody>
</table>
Conform provides a simple, easy-to-use method of importing data into the program. Users are able to perform a quick drag and drop function to add the desired data, allowing for near-real-time visualization, editing, and creation of data.

### 2.1 How to Import Data

1. Browse to the file or folder you wish to load into Conform in Finder or Windows Explorer.
2. Drag and drop the folder into the Conform application window.

Alternatively:

1. Click the *File* menu.
2. Select *Import Data...* (Alt+D)
3. In the *Import Data* window, locate and select the desired data.
4. Click the *Open* button.
**Hint:** The Import Data function will remember the last location data was imported from.

Conform imports data to correspond to the file folders that have been imported. Conform will find all supported files within the selected folders.

**Supported File Types**

**2.1.1 Log Output**

Displays errors, warnings, and general logging information. To enable Log Output, view View.

**2.1.2 Task Monitor**

Displays information about data being loaded as well as information about task execution where applicable such as exporting data. To enable Task Monitor, view View.

**Hint:** Task Monitor is useful for monitoring the progress of large datasets imports.
2.1. How to Import Data
CHAPTER
THREE

PROJECTS

Conform projects allow the user to save the state of the current session. This includes which files are loaded, their organization in the project browser, and various other settings which have been customized by the user (ex. colors in a layer property).

3.1 Project Browser Controls

- **New Layer** – Prompts the Add Layer window to appear.
- **Add Group** – Creates a Group within loaded data files.
- **Delete Selected** – Deletes selected items within the Project Browser.
- **Show/Hide** – Toggles the visibility of the selected layer.

Fig. 3.1: Conform begins a new project with the world borders base map.

3.2 Start a New Project

1. Click the *File* menu.
2. Select (New Project...) or press (Ctrl+N)

3.3 Open an Existing Project

1. Click the File menu.
2. Select Open Project... or press (Ctrl+O)
3. In the Open Project window, locate and select the desired project.
4. Once selected, click the Open button.

3.4 Saving Projects

1. Click the File menu.
2. Select Save Project or Save Project As...(Ctrl+S).
3. In the Save Project window, navigate to the desired save location.
4. In the Save Project window, type the file name in the File name: field.
5. Once completed, click the Save button.

**Hint:** Conform projects end with the extension.cfproj. Once saved, you can find the project files in Windows Explorer and double click them to open the project in Conform.

3.5 Groups

To group multiple items within the Project Browser:

1. Select the files to be added to a group by using the Shift or Ctrl keys.
2. Once selected, click the Add Group icon.
3. A folder named New Group will be created with the selected information.
4. To rename the group, single click the folder name.
3.6 Priority

Layer order is important, not only because it serves as a useful organizational tool, but because it defines the layer priority. Layers are visually prioritized from top to bottom within the project browser. Higher layers have higher priority.

For example, in the figure below the user has the vectors folder at the top of the Project Browser. The 2D map displays vector data on top of the elevation and imagery files that have also been dropped into Conform. In the figures below, the user has placed the imagery files to be a higher priority and then a lower priority. This order is reflected in the 2D map.

Fig. 3.2: Shows the imagery data underneath the vector data
Fig. 3.3: Shows the imagery data on top of the vector data after reordering the layers
Conform offers near-real-time visualization of GIS data in 2D and 3D for viewing and editing. This allows users to see their edits as they occur. For example, if changes are made to a building (location, height, etc.), these changes are reflected almost immediately in both the 2D and 3D view.

### 4.1 Navigating the 2D Map

1. In order to Pan, use the left or middle mouse button, click and drag anywhere on the map.
2. In order to Zoom, use the mouse wheel, scroll up (zoom in) or down (zoom out) to specific areas.

**Hint:** The motions are scaled so that they are more sensitive when the view is zoomed in.

### 4.2 Mouse Modes

Mouse Modes in Conform provide a variety of functions in the 2D Map. They function as radio buttons, meaning that only one option can be selected at a time.
**Pan and Zoom** – User can pan the map using a click and drag method. User is able to zoom using the scroll wheel of a mouse.

**Select Features** – User is able to select a rectangular portion of the map using a click and drag method. Selections will be outlined.

**Edit Tool** – User is able to toggle this function to edit layers, building locations, polygons, etc.

**Vertex Edit Tool** – Toggles the vertices for polygons to be edited and adjusted.

**Measurement Tool** – Users can measure distances and areas by drawing lines and polygons over the map view.

**Feature Identify** – User is able to identify a feature from within the 2D Map.

### 4.3 Go To Location

The Go To Location tool provides users a quick method of navigating to a known location using its longitude and latitude.

1. Click the *Go to location* icon in the Main toolbar.
2. The *Go to location* window will appear.
3. Enter the desired longitude and latitude of a location.
4. Click *OK*.
5. Conform will zoom to the entered coordinates within the 2D Map.

**Hint:** Users can see the longitude and latitude of any location by moving their mouse within the 2D map. Conform provides this information in the bottom right corner.
4.4 Map Scale

To set the scale:

1. Press the Map Scale button in the status bar.

1. Select from the pre-defined scale values by using the drop-down arrow and pressing OK.
2. You may also enter a custom value by entering it manually and pressing OK.
**4.5 Map Measurement Tool**

The 2D measurement tool allows users to measure distances and areas by drawing lines and polygons over the 2D map.

1. Click the *Map Measurement Tool* icon on the main toolbar.

2. Use the *L* (length) and *A* (area) icons to switch between Linear and Area measurement modes. The appropriate units will be displayed in the adjacent dropdown in each mode. As different units are selected, they will be updated within the window.

3. Using the cursor, draw a line or polygon to determine the measurement needed.

4. Click the *X* button to clear accumulated measurements and start over.

**Hint:** Multiple consecutive measurements will be summed in the sum field until measurements are cleared using the *X* button.
4.6 Set Coordinate System

Conform allows you to view the map in a variety of projected and geographic coordinate systems. To change coordinate systems:

1. Select Map > Set Coordinate System....
2. Select a projection from the list and press OK.
   • You can also use the Filter option to refine your search.
3. The map view will be displayed in the selected coordinate system.
4.7 3D Preview

In order to bring up 3D Preview, do the following:

1. Right click on the 2D map.
2. Select *Show 3D Preview Here*.
3. A 3D Preview window will appear with a visualization of your data.

**Hint:** The icon will also open the 3D Preview window.
4. Right click on the 2D map.
5. Select Show 3D Preview Here.
6. A 3D Preview window will appear with a visualization of your data.

The position of the preview’s eye point is indicated as a wedge-shaped overlay on the 2D Map. It follows the preview to help identify where it is located. All project contents are used to generate the 3D visualization.

Users are able to quickly reposition the 3D preview camera by repeating the above steps.

### 4.7.1 Navigating in 3D Preview

The following controls will assist the user in navigating through a 3D preview of their data:

- **W** – Move Forward
- **A** – Move Left
- **S** – Move Backward
- **D** – Move Right
- **E** – Move Up
- **Q** – Move Down
- **T** – Toggle 3D Preview Window to Always Be On Top
- **H** – Toggle Directions in 3D Preview Window
- **V** – Take a Screenshot
- **Shift** – Increase Acceleration
- **Left Mouse** – Drag to Look Around
This keyboard and mouse behavior emulates the behavior of many first person video games.

**Hint:** Screenshots taken in 3D Preview will be placed in a desktop folder titled *Conform Screenshots.*

### 4.7.2 2D Map Follows 3D Preview

To ensure that the 2D map reflects what is being seen in the 3D preview, be sure to use the Follow On Map feature. In this mode, the 2D Map will be updated periodically with the 3D Preview’s view position.

1. In the 3D Preview window, right click.
2. Select *Map follows preview.*

**Hint:** There is a short timeout that is reset any time motion is performed in the 3D Preview, so the map will not update until the 3D navigation has settled for 5 seconds to prevent excessive redraw behavior as the user navigates.

### 4.7.3 3D Preview Follows 2D Map

To ensure that the 2D map reflects what is being seen in the 3D preview, be sure to use the Follow On Map feature. In this mode, the 2D Map will be updated periodically with the 3D Preview’s view position.

To ensure that the 3D preview window reflects the movement within the 2D map, be sure to enable the *Map follows preview* feature. In this mode, the 3D preview view will follow as the user navigates the 2D map.

1. In the 3D Preview window, right click.
2. Select *Preview follows map.*
4.7.4 3D Preview Properties

The Preview Properties dialog allows the user to configure the behavior of the 3D Preview. While some changes can be seen immediately, the 3D Preview should be closed and reopened for all options to take effect.

To open the Preview Properties dialog, do the following.

1. On the main menu, click *Tools*.
2. Select *Preview Properties*.
Warning: Setting any of the following options too high may impact performance.

There are multiple Preview Property options.

- **Tiles per side**: This number represents how many layers of tiles will surround the tile that the user is currently directly over. For example, setting this to 0 would only display a single tile. Setting this to 1 would add a single layer of tiles around the current tile for a total of 9 tiles in view. Setting this to 2 would add two layers for a total of 25 tiles in view, etc.

- **Number of posts**: This number represents the resolution of a single tile’s geometry. Setting this to 256 would make the tile’s geometry a 256 x 256 grid. At 512, the tile’s geometry would be 512 x 512. To appreciate this effect, the user can press Tab to view a wireframe model of the tile and see the number of posts increase at higher resolutions and decrease at lower resolutions.

- **Image raster size**: This number represents the resolution of a single tile’s imagery texture.

- **Tile level**: This number controls the geographic size of tiles in the 3D Preview. A smaller number means larger tiles.

- **Restore Defaults**: Sets the above options to their default values.
Conform supports the concept of a *Base Map layer*, which is an easy way to add frequently used layers of data below your own GIS data. Conform comes equipped with MapQuest and Bing satellite imagery, as well as a world borders Shapefile.

### 5.1 Adding a Base Map

1. Click the *Tools* menu.
2. Select *Add Base Map*.
3. In the *Add Base Map* window, select the desired base map layer.
4. Click the *OK* button or *double click* to add the base map to your project.

Tip: Base Maps can also be accessed by clicking the 🌍 icon.
5.2 Add Default Base Map

1. Click the Tools menu.
2. Select Add Base Map.
3. In the Add Base Map window, select the desired map layer.
4. Click the Make Default button.
5. Click the OK button.
6. The selected Base Map will now appear in all new projects.

**Hint:** Only one Base Map may be made default at a time.

5.3 Clear Default Base Map

1. Click the Tools menu.
2. Select Add Base Map.
3. In the Add Base Map window, select the bold map layer.
4. Click the Clear Default button.
5. Click the OK button.

5.4 Add New Base Map

To add a custom base map:

1. Open the Base Maps dialog.
2. Press Add...
3. Complete the fields in the Add New Base Map dialog window and press OK.

4. The new base map should now appear in the list.
Note: At this time, only WMS and Arc Image Server base maps are supported for adding, editing, cloning, and deleting.

5.5 Clone Base Map

To clone a WMS base map:

1. Open the Base Maps dialog.
2. Select an existing custom Wms base map and press Clone...:

3. You will be presented with the Add New Base Map dialog.

4. Make the desired changes and press OK to save.
5. The new base map should now appear in the list.
   • Note: At this time, only Wms base maps are supported for adding, editing, cloning, and deleting.

5.6 Edit Base Map

To edit a WMS base map:

1. Open the Base Maps dialog.
2. Select an existing custom WMS base map and press Edit...:

3. You will be presented with the Add New Base Map dialog.
4. Make the desired changes and press OK to save.

**Note:** At this time, only WMS base maps are supported for adding, editing, cloning, and deleting.

### 5.7 Delete Base Map

To delete a WMS base map:

1. Open the *Base Maps* dialog.
2. Select an existing custom WMS base map and press *Delete*:

*Note:* At this time, only WMS base maps are supported for adding, editing, cloning, and deleting.
5.7. Delete Base Map
Conform includes a *simple* geocoding tool, which accesses MapQuest’s API to map addresses and locations.

### 6.1 Lookup Address

1. Click the *Tools* menu.
2. Select *Look up address* . . .
3. In the *Search for Address* window, type the location into the *Search terms* field.
4. Click the *Search* button.
5. In the *Results* box, double click the desired location.

6. The map will focus on the selected location. These will be indicated with markers.

7. Click the *Close* button.

**Hint:** Address look up can also be accessed by clicking the icon.
7.1 Selecting a Feature

1. Enter Select Features mouse mode.

2. Using the left mouse button, click on a feature. Selected feature(s) are indicated with a cyan outline.

3. **Alternatively, you can lasso select multiple features.**
   - To lasso select, use the left mouse button to drag a shape around the desired area.

If a layer is open and contains a selected feature, it will be highlighted in the *Attribute Table*.

**Hint:** In this mode, the middle mouse button (for pan) and the mouse wheel (zoom) both as they did in the pan/zoom mode.
7.2 Creating New Layers

1. In the Project Browser, click the New Layer icon.

2. In the Add Layer window, enter the full path to the name of a new Shapefile to create in the Dataset Name: field. (e.g. d:\mydata.shp)
3. Choose the geometry type from the *Geometry Type* dropdown menu.

4. Click the *Add Column* button.

5. To rename each column, double click each column name.
6. Select the column type in the *Type* dropdown menu.
7. Click the **OK** button.

### 7.3 Editing Existing Layers

1. In the *Project Browser*, locate the layer to be edited.
2. Right click the selected layer.
3. Select *Start Editing Layer* from the pop up menu.
Hint: If for some reason the layer isn’t editable, it may be due to filesystem permissions or that the source file is on a read-only medium.

Hint: Layers that are editable will be marked with a next to the layer name in the Project Browser.

### 7.4 Feature Identify Tool

The Feature Identify tool allows users to identify features from within the 2D Map.

1. Click the Feature Identify icon in the Map toolbar.
2. The Feature Identify window will appear. Select the desired features within the 2D Map.

3. As features are selected and highlighted on the 2D Map, they will be listed under their corresponding layer name in the tool’s window.

4. Click on a listed feature in the Feature Identify window. The attribute values for this feature will be listed.

*Tip:* Feature Identify allows users to switch identification modes. Using the Identify From drop down menu, choose to only show items from the topmost layer, only visible layers, all layers, or a specific layer of interest.
Conform allows users to edit data within the 2D window. This includes selecting, editing, moving, and creating features, and vertex editing. In order to perform these edits, layers must be editable (see Editing Existing Layers, the same as 3D edits).

8.1 Adding Vertices to Features

1. Follow the Editing Features instructions.
2. Click and drag any light-gray, midpoint vertices to add and position the new vertex.

Tip: Any shape can be refined by repeatedly splitting existing edges.
8.2 Moving Features

1. Make the layer editable.
2. Click the (Edit) tool.
3. Select the feature to be moved.
4. Once the feature is selected, the cursor will change.
5. Click and drag the feature to the desired location.
6. The feature can now be saved in this location.
8.3 Creating Features

1. Make the layer editable.
2. The Editable Layers window will appear on the right. Select the desired layer.
3. In the Tool Selection window below, select the Create Polygon option.
4. Using the crosshair cursor, click the left mouse button to place vertices in the desired layout.
5. Double click the mouse to finalize the new feature. A final point will be inserted at the double click location.
8.3. Creating Features
8.4 Vertex Editing

1. Follow the Selecting a Feature directions.
2. Click the (Vertex Edit) tool.

8.4.1 Vertex Points

- **Solid Green Block(s)** – Existing Point
- **Solid Red Block** – Last Point Created
- **Transparent Gray Block(s)** – Potential New Point
- **Hollow Block(s)** – Selected Point

**Hint:** To undo an unwanted vertex, press the scape key. After a feature has been created, it can be removed using the Undo function (Ctrl-Z).
8.4.2 Click and drag any existing vertex
8.4.3 Click an edge or line to move it
8.4.4 Lasso select multiple vertices to move them at the same time
8.5 Deleting Features

1. Follow the *Selecting a Feature* directions.
2. Right click the selected feature.
3. Select *Delete Selected Features*.

### 8.6 Saving Changes

1. In the *Project Browser*, locate the edited layer.
2. Right click the selected layer and select *Stop Editing Layer*.
3. Users will be prompted by the *Save Changes To Layer? Window*.
4. Click the *Yes* button to save changes.
Conform allows users to edit data within the 3D Preview window. This includes vector and elevation editing. In order to perform these edits, layers must be editable (see Editing Existing Layers.)

9.1 3D Vector Editing

Layers must Editing Existing Layers in order to perform 3D vector edits.

3D Vectors are editable in 3 different ways.

- **Translate** freely translate models in both X and Y directions.
- **Scale** adjusts the height of models.
  - Note: This option is only available for extruded areal features with a height column specified.
- **Rotate** allows models to be re-oriented about the z-axis.
After initiating an edit operation by double clicking a model, editing can be performed by clicking and dragging the different handles.

<table>
<thead>
<tr>
<th>Handle Color</th>
<th>Direction/Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue</td>
<td>X</td>
</tr>
<tr>
<td>Red</td>
<td>Y</td>
</tr>
<tr>
<td>Green</td>
<td>Height</td>
</tr>
<tr>
<td>Magenta</td>
<td>Rotation</td>
</tr>
<tr>
<td>Yellow</td>
<td>Active Handle</td>
</tr>
<tr>
<td>Grey Box</td>
<td>Model Center</td>
</tr>
</tbody>
</table>

### 9.1.1 Translate

1. Double click the desired model.
2. To translate along the X or Y axis, click and drag the X or Y handle.
3. To freely move the model in the X/Y plane, click and drag the **Model Origin Handle**.
4. To save changes, follow the *Saving Changes* steps.

### 9.1.2 Scale

1. Double click the desired model.
2. Click and drag the **Height** handle.
3. While dragging, the relative scale and absolute height (in meters) will be displayed.
4. To save changes, follow the *Saving Changes* steps.
Tip: This handle will only appear when editing extruded areal features with a height column specified. It will not appear when editing point models or other editable features.

9.1.3 Rotate

1. Double click the desired model.

2. **Click and drag the Rotation Handle.**
   - To snap to a fixed increment, hold the Ctrl key and rotate the mouse wheel to adjust the snap increment up or down.
   - The new orientation angle will be displayed as the feature is rotated.

3. To save changes, follow the *Saving Changes* steps.

Tip: When rotating a point model with a defined orientation column, this action will update the orientation attribute value. When rotating an extruded areal, the feature vertices will be updated.
9.2 3D Areal and Linear Vertex Editing

Layers must *Editing Existing Layers* in order to perform 3D areal and linear vertex edits.

Enter *3D Preview*.

Tip: At any time, edits can be undone by *pressing* the escape key.

To enter vertex editing mode hold *ctrl* and *double click* on the feature in the 3D Preview window.
9.2.1 To Move a Vertex

Existing vertices will appear as a larger, bright green circles.
1. Left click and drag the desired vertex.
Tip: Once selected, a vertex will be highlighted yellow.

9.2.2 To Add a Vertex

Vertices that can be added will appear as smaller, dark green circles.
1. Left click on the desired vertex.
2. The vertex will remain in this location unless dragged by the user.

9.2.3 To Delete a Vertex

1. Left click the desired vertex. The vertex will appear yellow.
2. Press the delete key.

9.2.4 Committing Changes

1. Double click outside of the feature or press the space bar.
This temporarily commits the feature while in editing mode, but does not save. To save the changes, follow the Saving Changes steps.
Conform allows users to edit elevation raster data within the 2D Map and 3D Preview window. This includes elevation editing using a brush and high resolution elevation inset creation. In order to perform these edits, layers must be editable (see Editing Existing Layers.)

10.1 2D/3D Elevation Editing

Modifications can be performed to elevation raster layers using various brush types. This can be done in both the 2D Map and 3D Preview.

10.1.1 Selecting a Brush & Brush Properties

1. Select the desired layer in the Project Browser.
2. Right click and select Start Editing Elevation.
3. The Elevation Editor panel will appear.
   • Select a brush from Brush Properties.
   • Select a Brush Mode from the dropdown. Brush modes are described below.
   • Set a Brush Size. The brush size determines the area of impact for edits.
   • Set a Brush Opacity. The opacity determines the level of impact for edits. A lower opacity results in a less significant change in elevation while a higher opacity results in a more significant change in elevation.

10.1.2 2D Editing Properties

These properties are only applicable to the 2D Map view.

1. Smooth Elevation enables bi-linear filtering which smoothly blends between adjacent pixels in the elevation raster. With the option disabled, the 2D Map will display the raw pixel data view of the elevation raster.
   • Note: This option only affects how the data is presented on the 2D Map and has no affect on how the data is written when saved.
2. Show Raster Grid Overlay will overlay a grid on the elevation raster. Each cell of the grid represents a single pixel in the source elevation raster.
   • Note: Enabling this option may affect performance when panning and zooming.
3. Grid Opacity controls the opacity of the grid.
Tip: New brushes can be installed by clicking Manage Brush Paths and then using the Add... or Remove options in the Manage Brush Paths dialog.

Fig. 10.1: Elevation Editor panel

10.1.3 2D Editing Mouse Mode

If at any point you exit the 2D Editing Mouse Mode, you will no longer be able to make edits on the 2D Map. You can re-enter the mode by clicking on the following icon in the panel.

10.1.4 Brush Modes

- Raise will add elevation to the painted area.
• **Lower** will remove elevation from the painted area.

• **Set Elevation** will apply a fixed elevation to the painted area.

  – Middle clicking on the mouse will sample the elevation at the position of the mouse cursor in both the 2D Map and 3D Preview. Alternatively, you can manually enter the desired elevation value into the *Elevation* field of the Elevation Editor panel.

### 10.1.5 Brush Painting

The brush cursor will appear as a brush on the 2D Map and on the 3D Preview’s terrain skin, indicating the editing position, brush size, and brush opacity. The way the terrain surface is affected is controlled by the settings indicated in Brush Properties.

To start Brush Painting:

1. Hold *Ctrl* and the *left mouse button*.
2. Drag the brush indicator to paint on the terrain skin.
3. The specified **Brush Mode** will determine the action that occurs in 3D Preview.

To change the Brush Size:

1. Use the **Brush Size** slider in the Elevation Editor or hold *Ctrl* while using the mouse’s scroll wheel. Applies to 2d Map and 3D Preview.

To change the Brush Opacity:

1. Use the **Brush Opacity** slider in the Elevation Editor or hold *Alt* while using the mouse’s scroll wheel. Applies to 2d Map and 3D Preview.

*Tip: Click *Undo Last Operation* in the Elevation Editor panel to undo the last brush operation.*
Fig. 10.2: 2D Map Elevation Editing (Grid and Smoothing Enabled)
10.2 Elevation Inset

The Elevation Inset tool allows for the creation of a high resolution inset from an elevation raster.
10.2.1 Inset Layer Creation

To create a new elevation inset layer, do the following.

1. In the Elevation Editor, click Create Inset...

2. Choose values for:
   - Output Path
   - File Format
   - Data Type
   - Origin
   - Pixel Dimensions
   - Resolution

3. To sample an existing elevation layer, choose the layer to sample from the Sample Existing Layer dropdown.
   - If not sampling an existing elevation layer, choose an Initial Elevation value.

4. The new layer will be added to the top of the Project Browser.

10.2.2 Terrain Leveling

There are two primary methods for elevating areas.
- **Interactive Selection** - allows the user to define a polygonal shape using the mouse cursor.
- **Selected Features** - allows the use of an areal feature to define the polygon shape used for the elevate area selection.

*Elevation Methods* common to both Interactive Selection and Selected Features

- Select the *Elevation Method* from the following:
  - *Fixed* - Sets an exact elevation for all points in the defined area.
  - *Sloped* - Allows the user to define a slope with a beginning *A* and end *B* which will create a slope from point *A* to point *B*. If the slope line is defined within the shape, any points beyond *A* or *B* will be assigned their respective values to their nearest defined point. So all points within the area, but prior to *A* will be set at the value *A*. Likewise, all points within the area, but beyond *B* will be given the value *B*.
  - *Center of Feature* - Sets the elevation for all points in the defined area to the elevation value at the center of the feature.
  - *Average of Border* - Sets the elevation for all points in the defined area by taking the average elevation of all the border point’s elevation values.
  - *Min of Border* - Sets the elevation for all points in the defined area to that of the border’s lowest elevation point value.
  - *Max of Border* - Sets the elevation for all points in the defined area to that of the border’s highest elevation point value.

**Interactive Selection**

1. In the *Elevation Editor*, click *Elevate Area*.
2. Select the desired elevation raster layer.
4. Press the *Define area* button.
5. Using the crosshair cursor, draw the appropriate shape on the 2D Map. Double click the final point to close the
6. Select a *Smooth Range* (The *Smooth Range* defines the outer padding that will be added to the user-defined shape that was drawn. This allows the user to define a smooth transition between the defined shape and the surrounding elevation. For example, a range of 10 would create a gradual slope extending outward 10 meters in all directions from the original polygonal shape which would level out with the surrounding elevation.)

7. Select an *Elevation Method* (described above).

8. *(Applies to sloped method only)* Using the crosshair cursor, select the start and end points of the terrain slope. These are indicated with A and B.

9. *(Applies to sloped method only)* Enter the *Elevation at A* and *Elevation at B* values.

10. Click *Apply*.

11. Changes will be shown in 2D and 3D.
Selected Feature

1. In the Elevation Editor, click Elevate Area.
2. Select the desired elevation raster layer.
4. Select a feature in the map window (see Selecting a Feature.)
5. Select the Feature Layer associated with the selected feature.
6. Select a Smooth Range (The Smooth Range defines the outer padding that will be added to the user-defined shape that was drawn. This allows the user to define a smooth transition between the defined shape and the surrounding elevation. For example, a range of 10 would create a gradual slope extending outward 10 meters in all directions from the original polygonal shape which would level out with the surrounding elevation.)
7. Select an Elevation Method (described above).
   • Elevation methods specific to Selected Feature * Attribute Table - In addition to the elevation methods listed above, you may also define the elevation based on a value from the attribute table.
      – Select Attribute Table from the Elevation Method dropdown.
      – Select the appropriate column where the values are stored.
      – Sets the elevation for all points in the defined area to the elevation value defined by the attribute value.
         * Note: Non-numeric values or string values that cannot be converted to numeric values will be ignored and the process will fail.
8. (Applies to sloped method only) Using the crosshair cursor, select the start and end points of the terrain slope. These are indicated with A and B.
9. (Applies to sloped method only) Enter the Elevation at A and Elevation at B values.
10. Click Apply.
11. Changes will be shown in 2D and 3D.
10.2.3 Brush Modes

- Raise will add elevation to the painted area.
• Lower will remove elevation from the painted area.
• Set Elevation will apply a fixed elevation to the painted area.
  – To set a fixed elevation value, middle click the mouse on the desired area. This will sample the elevation. Alternatively, enter the value into the Elevation Editor panel.
Layer properties allow the user to make aesthetic changes to desired layers.

11.1 View

In the Layer Properties window, users can change the Opacity of a specific layer.

11.2 3D Preview

In the Layer Properties window, users are able to adjust multiple aspects of the 3D Preview function. Controls are dependent on the type of layer selected (point, line, area).

11.2.1 Features

- Users can toggle if a layer is included in 3D Preview.
• **Users can select what the layer is set to **Show As. This includes: Extruded volumes to be used for buildings and other above ground features.

• Users can toggle if the 3D Preview should use a data table column to determine height.

• **Height Column** will determine which data column is used for height data.

• **Minimum Height** will ensure all buildings have a minimum height displayed.
• **3D Polygons** to be used for drawing the feature in the 3D Preview without modification to its elevation or Z-values. Users can change the **Color** if 3D Polygon is selected.
• Draped Polygons to be used for natural elements, such as a body of water. Users can change the Color if Draped Polygon is selected.
11.2. 3D Preview
11.2.2 Roads

- *Drape on Terrain* - See description above.
- *Color* - Road color.
- *Minimum Width* - Sets road width when *Use Data Table Column to Determine Width* is not selected. Otherwise, this value prevents the data column value from being too small due to missing or incorrect data.
11.2.3 Walls

The user can choose the direction that the walls extrude. There are three directions that the walls can be extruded: center, left, and right. The extrude direction is dependent on the direction of the linear feature they are extruded from. Additionally, the wall segments can be subdivided to better follow terrain if elevation data is present. If enabled, any given segment will be subdivided so that it is no longer than the value specified (in meters).
11.2.4 Powerlines

Linear features may be viewed as powerlines. A powerline pole will be placed at each vertex. A powerline line will connect each pole.

- **Height** - can be set using the Minimum Height field or by a user-selected attribute when ‘Use Data Table Column to Determine Height’ is checked.
- **Radius** - determines the radius of each powerline pole (in meters).
- **Geometry detail** - determines the number of subdivisions to use when constructing the pole’s cylindrical shape. A lower setting will produce a fewer-polygon shape that may appear more blocky, but may improve performance if there are many powerline objects present in the scene. A higher setting will produce a greater-polygon shape that better approximates a smooth cylinder, but may reduce performance if there are many powerline objects present in the scene.
11.3 Layer Style

In the Layer Properties window, users are able to change the colors used for their data.
11.3.1 Features
• *Stroke Color* determines the color of the layer outline.
• *Stroke Width* determines the width of the outline.
• *Stroke Enabled* toggles the stroke effect.
• *Fill Color* determines the color of the layer footprint.
• *Fill Enabled* toggles the fill effect.

11.3.2 LIDAR

• Users can toggle if LIDAR points are seen in 3D Preview.
• *Color* determines the color of all LIDAR points in both 2D and 3D.
• *Color From Height* allows users to color LIDAR points based on height data. This can be restricted to create a larger scale of color when points are closer together.
  – Users can click the *Apply To All Layers* button when they have applied preferred color settings.
• *Modify By Intensity* Users can toggle to modify points by intensity if an intensity property is present in the data.
• *Point Size* determines the size of each individual LIDAR data point.
This figure shows LIDAR Data using the Color From Height feature.

This figure shows LIDAR Data using the Color feature.

### 11.3.3 Elevation

Users are able to adjust the following elevation data setting intensities.

- Altitude
- Azimuth
- Z Factor
- Saturation
11.4 Symbology

In the Layer Properties window, a different single symbol for each added feature layer. Users are able to customize these layers to fit their specific needs.

11.4.1 See Layer Symbol

1. Locate the desired layer in the Project Browser and right click.

2. Select Properties.

3. Click the Symbology tab.

The table will display the symbol assigned automatically by Conform to the selected layer. This will be labeled as <Default> symbol for the layer.
11.4.2 Choosing a Single Layer Symbol

1. Follow the *See Layer Symbol* steps.
2. Double click the image in the *Symbol* column.
3. Select the desired symbol.
4. Click *Apply*.
5. Click *OK*. 
11.4.3 Choosing Symbols Based On Attribution

This function supports varying symbol selection based on feature attribute values.

1. Follow the See Layer Symbol steps.
2. Click Select Fields...
3. Desired field values can be selected using the checkbox next to the field names.
4. Click OK.
5. Each field selected in step 3 will appear as a new column in the Symbology tab of Layer Properties.
6. Click Add Row.
7. In the newly added row, enter a value in the appropriate column for each field selected.
8. Double click the image in the Symbol column.
9. Select the appropriate symbol to be assigned if the values in this row are matched.
10. Click OK.

An example of steps 7 – 10 is below. Every feature except those whose “label” field matches the value of “crop_land” will be colored with the <Default> symbol. Those who match will be colored with the rose colored symbol.

11.4.4 Editing Symbols

1. Follow the Choosing a Single Layer Symbol steps.
2. Click Edit...
3. The Edit Symbol window will appear.

This editor allows users to change a symbol type, properties, and layers. Layers can be added or removed to produce more complex symbols. These changes are reflected in real time in the Preview window.
Attribute Table values may be viewed or edited. To make edits to attributes within a layer, ensure that it is currently editable. To do this, follow the Edit Existing Layers section. To view the Attribute Table window, follow the directions below. Only vectors can be seen and edited in the Attribute Table window.

12.1 Show Attribute Table

1. Right click the desired layer and select Show Attribute Table.

2. The Attribute Table window will pop up displaying all attributes in the specified layer.

Tip: All editable layers will appear as different tabs within the Attribute Table window.
12.2 Attribute Table Functionality

- **Show only selected rows** – Users are able to select which layers they would like to view.
- **Make layer editable** – Users are able to make layers editable from the Attribute Table window.
- **Zoom to selected rows** – Users are able to quickly zoom to any feature from within the Attribute Table window.
  - To select one attribute, click the *Feature ID* column.

- To select multiple attributes, hold the Shift or Ctrl key while clicking the *Feature ID* column.
To use the *Show only selected rows* feature, select the desired rows and click the *Show only selected rows* button. The selected features will appear highlighted in the 2D Map.
To zoom to selected rows, select the desired rows and click the *Zoom to selected rows* icon.

### 12.3 Attribute Table Sorting

Users are able to sort the attribute table by the desired column in ascending or descending order.

1. Follow the *Show Attribute Table* steps.
2. Locate the desired column to sort by and click the column heading.
   - Click once for ascending order.
   - Click twice for descending order.
3. An arrow will appear next to the selected column name indicating ascending or descending order. Users can continuously toggle the order by clicking the column heading.
4. To return to the original ID sort order, click the empty cell in the top left corner of the Attribute Table.

12.4 Select By Attributes

This feature allows the user to select attributes using a query filter’s where clause. The selection results can be viewed on the 2D Map or in the Attribute Table of the selected layer.

Currently, File Geodatabase is the only supported dataset type.

To access the Select By Attributes dialog: #. In the Main Toolbar, click Tools. #. Select Select By Attributes.
The Select By Attributes dialog options are outlined below.

**Layer** - Allows the user to select the feature layer which the selection applies.

**Select only from visible layers** - If this checkbox is checked, only layers that are marked as visible in the project browser will populate the Layer dropdown. Otherwise, all valid File Geodatabase layers will be displayed in the Layer dropdown.

**Where Clause** - The expression that will constrain the features returned from the query filter. For example, `height_above_surface_level > 7` will select all features whose height above surface level attribute is larger than 7. The expression `building_function = 'government'` will select all features whose building function attribute is government.

**Method** - The selection method determines how the selection is to be applied. There are four options:

- *Create a new selection* - Deselects any currently selected features and makes a new selection based on the where clause expression.
- *Add to current selection* - Keep current selection, if any, and makes additional selection based on the where clause expression.
- *Remove from current selection* - Deselects features from the current selection based on the where clause expression.
- *Select from current selection* - Selects a subset of features from the current selection based on the where clause expression.

Note: The number of returned results will be displayed briefly in the status bar. If no results were found or if an error in the where clause expression is found, the number of results found will be displayed as 0.
12.4. Select By Attributes
12.5 Editing Attributes

1. Follow the Attribute Table directions above.
2. Double click cells in the Attribute Table window to enter or change values.
To support group reviews or analysis sessions, Conform supports the concept of viewport synchronization. The service consists of a synchronization server and a client plugin for Conform. A plug-in is also available for ArcGIS for Desktop.

### 13.1 Connecting to the Sync Server

After completing the Launch Sync Server steps, do the following.

1. Click the **Tools** menu.
2. Click **Connect to Sync Server**…
3. **In the Sync Server dialog box, enter the address in the following form:**
   - `<ip>:<address>`

![Connect to Sync Server dialog box](image)

4. Fill in the **Your Name** dialog box.
5. Click **Connect**.
6. If on Windows, connection to the Sync Server will be indicated in the system tray.
7. To see a list of all connected users, right click the sync icon in the system tray.

**Hint:** Connect to Sync Server can also be done through the icon on the main toolbar.

### 13.2 Launching the Sync Server

1. Click the *Tools* menu.
2. Click *Launch Sync Server*...
3. **Enter the desired port number.**
   - The default port number is 12436.
4. Click *Launch.*
• **Require Heartbeat** - The sync server will listen for a heartbeat from connected clients. If no heartbeat is received within 10 seconds, the client will be disconnected.

All local IP addresses are displayed for convenience. Users will need the IP address or computer name, in addition to the port number in order to connect.

### 13.3 Synchronization Service Controls

The sync service uses the concept of “control” to reflect who, if anyone, is driving the shared view. Any user has the ability to take control of the synchronization at any time. Users do not have to relinquish control in order for someone else to take it.

### 13.4 Quitting a Sync Session

If a user wishes to quit a sync session, they can click the *Connect to Sync Server* icon. This will disconnect the sync server. The button will no longer appear pressed in the Sync toolbar.

### 13.5 Closing the Sync Server

1. Right click the Sync Server system tray icon.
2. Select *Quit*.

### 13.6 Sync Status

Within the bottom right corner of Conform, users will be able to see one of four possible statuses.
• **Disconnected** – Not connected to sync server.
• **Connected** – Connected, but no user has control.
• **You have control** – You are in control. Movements you make on the map will be reflected on the maps of other connected users.
• **Username** has control – Another user is in control. Movements that *Username* makes will be reflected on your map.

### 13.7 Sync Toolbar

- **Connect to Sync Server** – Displays the Connect to Sync Server window.
- **Take/Release Control** – Allows user to take over or release control of a synchronization session.
  - Icon will appear greyed out until connected to Sync Server.
- **Resume Being Controlled** – Allows users to resume being controlled during a synchronization session if independent exploration has occurred.
  - Icon will appear greyed out until connected to Sync Server.

### 13.8 Taking Control

1. Ensure that you are connected to a sync server (see *Connecting to the Sync Server*.)
2. Click the **(Take/Release Control)** icon on the main toolbar.
3. Once you have taken control, the icon will appear pressed.
13.9 Forcing Control

During a sync session, any connected user is able to force the view of participants to a particular location.

1. Right click the desired area of the map.
2. From the drop down menu, select Force Snap View Here.

3. All participants will be forced to the location.

13.10 Independent Exploration

In synchronization mode, users are able to independently explore using the pan/zoom map functions. Users may resume being controlled by clicking the (Resume Being Controlled) button.
Conform can read and write feature data from ESRI ArcGIS SDE workspaces. Conform utilizes the ESRI COM interface with existing ArcEngine or ArcDesktop licenses to manage SDE connections.

ArcSDE is ESRI’s technology for accessing and managing geospatial data within relational databases. ArcSDE technology supports reading and writing of multiple standards including (among other data storage options) Open Geospatial Consortium, Inc. (OGC), standards for simple features; the International Organization for Standardization for Standardization (ISO) standard for spatial types; and the Oracle Spatial format.

14.1 Connecting a Workspace to SDE

1. Click the Tools menu.
2. Select Connect to SDE . .
3. Enter the appropriate information for the Instance and Database Name fields.
   - If Operating System Authentication is selected for Authentication Mode, the User Name and Password fields will automatically be filled by the Operating System.
   - If Database Authentication is selected for Authentication Mode, a User Name and Password will need to be entered by the user.
4. Click OK.

Tip: Connecting to SDE can also be done by clicking the icon on the main toolbar.
14.2 Connecting a Workspace to SDE via Connection String

This method exists as a shortcut to avoid typing in each field value manually.

1. Click the Tools menu.
2. Click Connect to SDE.
3. Select the Connection String tab.
4. Enter the string into the Connection String field. This is typically provided by a system administrator.
5. Click OK.

14.3 Changing SDE Connection Information

An ArcGIS license is required to connect to an SDE.

This function provides a method for users to edit SDE connection links in projects. It should be used if a Conform project has been configured extensively and a user wants to ensure all information is saved in case of changing connections.

To perform this action:

1. Click the Tools menu.
2. Click Reconfigure SDE Connection.
3. Double click the desired entry in the Existing Connections list.
   - The original configuration of each connection will be displayed. Make any necessary adjustments.
4. Click OK.
5. Reload the desired project to utilize the new database.

Tip: The Reconfigure SDE Connection window can also be accessed by clicking the icon on the main toolbar.
14.3. Changing SDE Connection Information

![SDE Connection Reconfiguration window](image)

Existing Connections: [RMORLAND\sqlexpress.test\sqlserver]
1. Locate the VCDR Error Navigation Tool icon in the Main Toolbar.

2. Enter a path to the output folder in the VCDR Results - Select Directory window. This path should contain one or more File Geodatabase folders.

3. Errors will be processed by the tool and displayed one at a time.

4. From the Filters section, choose between the Error Type or Status dropdown menus. This will restrict the number of features to what has been indicated.

5. To navigate errors, use the < and > buttons.

*Tip:* Navigation between errors can also be done pressing Ctrl+A and Ctrl+D.

The two features related to the error are displayed beneath the relevant details of the error. The attributes for the two features are displayed on the right side of the window.

Changes can be made to the features, as long as the layer is editable. This can be done by clicking the Edit icon next to the Feature.
Conform uses a simple license manager which allows you to request trials or enter purchased license codes.

### 16.1 First-Time Use

When you start Conform for the first time, you will be prompted to either request a trial license or enter an existing license key. If you haven’t purchased Conform, select *Request a temporary trial license* and click *OK* and continue to the following section.

If you have purchased Conform, skip ahead to *Using a Purchased License*.

![First-time use of the License Manager](image)

**Fig. 16.1:** First-time use of the License Manager

### 16.2 Requesting a Trial

GameSim provides temporary trial licenses of Conform as requested through the License Manager. To request a trial, click the *Request a temporary trial license* option on the *Get Started* dialog and then click *OK*. 
You will then be prompted for your name and email address. Be sure to use a valid email address, as this is where your license will be mailed.

After clicking *OK*, you will get a prompt to check your email and look for the license key.

---

**Fig. 16.2:** Requesting a trial license

**Fig. 16.3:** Successful trial request
Once you receive the email, find the two sections labelled **License Contents** and **License Code**:

```
License contents
------------------------ COPY BELOW THIS LINE ------------------------
license.expires: true
... sample license shortened ...
licensee.name: Full Name
------------------------ DO NOT INCLUDE THIS LINE ------------------------

License code
------------------------ COPY BELOW THIS LINE ------------------------
t8FQ2U3T7CX1aNp7KgUhHjFM5j32of132wf30f823f!#)*JFjd1edXq5+nUnpV1mYG2k
... sample license shortened ...
gqqogqEcrqhI8pe5mmArmbxJ4KqNhNjRg+MQ07uIrI2M2qLNE1fSpJ49ahqy7w==
------------------------ DO NOT INCLUDE THIS LINE ------------------------
```

Copy and paste the text indicated in the **License contents** field onto the **Add License Dialog**, and repeat for the **License code**.

![Add License Dialog](image.png)

**Fig. 16.4: Entering your trial license details**

Once you have entered the license details, click **OK** to continue. You will be prompted to authorize the license. Click **Yes** when prompted to authorize now.
When the authorization succeeds, you will be returned to the License Manager, and a new row will be present with your license summary. You will notice that the Authorized? field will indicate Yes, showing that the license has now been authorized and is ready for use.

Close the License Manager and Conform will launch and be ready to use.
16.3 Using a Purchased License

If you have purchased Conform on GameSim’s website, use the *Enter a license key* on the *Get Started* dialog, or choose *Add...* from the main License Manager window.

![Get Started dialog](image)

**Fig. 16.7: Get Started dialog**

You will need to check your email for your license information, then find the two sections labelled *License Contents* and *License Code*:

```
License contents
------------------------ COPY BELOW THIS LINE ------------------------
license.expires: false
... sample license shortened ...
licensee.name: Full Name
------------------------ DO NOT INCLUDE THIS LINE ------------------------

License code
------------------------ COPY BELOW THIS LINE ------------------------
t8FQ2U3T7CX1aNptKgLhhJfM5j32ofi32wf30f823f!#)*JFjd1edXq5+nUoPV1mYGZ6k
... sample license shortened ...
gqqogqEcrqhI8pe5mmArmbJ4KhNj9R+MQ07uzTrlZMVqLNE1fSpJ4ahqy7w==
------------------------ DO NOT INCLUDE THIS LINE ------------------------
```

Copy and paste the text indicated in the *License contents* field onto the *Add License Dialog*, and repeat for the *License code*. 

---

**16.3. Using a Purchased License**

123
Once you have entered the license details, click OK to continue. You will be prompted to authorize the license. Click Yes when prompted to authorize now.

When the authorization succeeds, you will be returned to the License Manager, and a new row will be present with your license summary. You will notice that the Authorized? field will indicate Yes, showing that the license has now...
been authorized and is ready for use.
Close the License Manager and Conform will launch and be ready to use.

### 16.4 Offline Licensing

If your computer is offline during the license setup process, you will be prompted to continue the process on the web from another computer. Click the links provided at each step and copy and paste the requested fields to another machine with internet access. Once complete, there is no difference between a license setup online or offline.